麻豆小视频在线观看_中文黄色一级片_久久久成人精品_成片免费观看视频大全_午夜精品久久久久久久99热浪潮_成人一区二区三区四区

首頁 > 編程 > C > 正文

貪心算法 WOODEN STICKS 實例代碼

2020-01-26 16:08:13
字體:
來源:轉載
供稿:網友

Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute. (b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output
The output should contain the minimum setup time in minutes, one per line.

Sample Input
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1

Sample Output
2 1 3

復制代碼 代碼如下:

#include<stdio.h>
 #include<stdlib.h>
 #include<string.h>
 #define N 5000;

 struct node
 {
     int l;
     int w;
     int flag;
 }sticks[5000];
 int cmp(const void *p,const void *q)
 {
     struct node *a = (struct node *)p;
     struct node *b = (struct node *)q;
     if(a->l > b->l) return 1;
     else if(a->l < b->l) return -1;
     else return a->w > b->w ? 1 : -1;
 }
 int main()
 {
     int t,n,cnt,cl,cw;
     int i,j;
     scanf("%d",&t);
     while(t--)
     {
         memset(sticks,0,sizeof(sticks));
         scanf("%d",&n);
         for( i = 0; i < n; i++)
             scanf("%d %d",&sticks[i].l,&sticks[i].w);
         qsort(sticks,n,sizeof(sticks[0]),cmp);
         sticks[0].flag = 1;
         cl = sticks[0].l;
         cw = sticks[0].w;
         cnt = 1;
         for( j = 1; j < n; j++)
         {
             for( i = j; i < n; i++)
             {
                 if(!sticks[i].flag&&sticks[i].l>=cl&&sticks[i].w>=cw)
                 {
                     cl = sticks[i].l;
                     cw = sticks[i].w;
                     sticks[i].flag = 1;
                 }
             }
             i = 1;
             while(sticks[i].flag)
                i++;
             j = i;
             if(j == n) break;
             cl = sticks[j].l;
             cw = sticks[j].w;
             sticks[j].flag = 1;
             cnt++;
         }
         printf("%d/n",cnt);

     }
     return 0;
 }

題意:

我們要處理一些木棍,第一根的時間是1分鐘,另外的,在長度為l,重為w的木棍后面的那根的長度為l', 重量w',只要l <=l' 并且w <= w',就不需要時間,否則需要1分鐘,求如何安排處理木棍的順序,才能使花的時間最少。

思路:

貪心算法。先把這些木棍按長度和重量都從小到大的順序排列。cl和cw是第一根的長度和重量,依次比較后面的是不是比當前的cl,cw大,是的話把標志flag設為1,并跟新cl,cw。比較完后,再從前往后掃描,找到第一個標志位為0的,作為是第二批的最小的一根,計數器加一。把它的長度和重量作為當前的cl,cw,再循環往后比較。直到所有的都處理了。

發表評論 共有條評論
用戶名: 密碼:
驗證碼: 匿名發表

圖片精選

主站蜘蛛池模板: 国产一区影院 | 91精品国产91久久久久久 | 亚洲激情91| 久久精品一区二区三区国产主播 | 国产亲子伦在线观看 | 91精品国产综合久久久动漫日韩 | 久久久久久久久久综合 | 免费在线观看成年人视频 | 在线视频a| 国产精品99一区二区 | 欧美精品一区二区三区久久久 | 鲁人人人鲁人人鲁精品 | 91精品国产91久久久久久吃药 | 成人h精品动漫一区二区三区 | 欧美精品一区二区三区四区 | 欧美日韩国产成人在线观看 | 天天草夜夜爽 | 毛片av网| 免费久久精品 | 黄色毛片观看 | 中文字幕专区高清在线观看 | 国产成人综合在线视频 | 天堂在线资源av | 成人男女激情免费视频 | 久久精品视频日本 | 国产青草网 | 特黄一区二区三区 | 久久777国产线看观看精品 | a网在线 | 久久一本日日摸夜夜添 | 99影视电影电视剧在线播放 | avav在线播放 | 农村寡妇偷毛片一级 | 香蕉久草视频 | av影片在线观看 | 精品国产乱码一区二区 | 欧美视频一区二区三区 | 久久国产精品一区 | 99成人精品视频 | 日韩视频在线一区二区三区 | 天天草夜夜爽 |